Excel – SVerweis

SVERWEISxl176

Die Wenn-Funktion kann nur sieben Verschachtelungen haben – sie ist aber schon vorher viel zu unübersichtlich. In vielen Fällen ist es praktischer, mit dem SVERWEIS zu arbeiten.

In einem privaten Schwimmbad wird nach Stunden abgerechnet. Da ein eifriger Schwimmer maximal 12 Stunden bleiben kann, gibt es zwölf verschiedene Preismöglichkeiten – eine Wenn-Dann-Funktion kommt also nicht in Frage.

Die Preisstaffelung schreiben Sie sich in einen eigenen Bereich der Tabelle, hier sind es die Spalten D und E. In unserem Fall muss die Preistabelle aufsteigend sortiert sein.

Dieser Bereich heißt “Verweistabelle”. Aus ihr werden die Preise berechnet, darauf bezieht sich die Funktion SVERWEIS.

Die Verweistabelle hat zwei Spalten – in Spalte D stehen die Stundenzahlen, in Spalte E die dazugehörigen Preise. Die Preise gelten immer “ab 2 Stunden” bzw. “ab 7 Stunden”.

Die Spaltenzahl der Verweistabelle spielt eine große Rolle. Sie müssen in der Formel angeben, aus der wievielten Spalte Sie Informationen benötigen. Der SVERWEIS arbeitet nicht mit den Spaltennamen C oder F, sondern mit der Spaltennummer aus der Verweistabelle: 2 oder 3. Wir werden die Informationen der zweiten Spalte benötigen (die Preise) und somit auf die Spalte 2 verweisen.

xl177In die Zelle B1 wird die Stundenzahl des Schwimmers eingetragen und in B2 soll der Betrag ausgegeben werden.

Die Schreibweise der Funktion SVERWEIS sieht so aus:

=Sverweis(Suchkriterium;Matrix;Spaltennr.;Verweis)
=SVERWEIS(B1;D2:E12;2)

Das Suchkriterium ist die Anzahl der Stunden aus der Zelle B1.

Unter der Matrix versteht man die Verweistabelle – also hier der Bereich von D2:E12.

Die Spaltennummer oder der Spaltenindex ist die Nummer der Spalte aus der Verweistabelle, die man braucht. Hier wird die zweite Spalte benötigt. In der ersten Spalte stehen die Stundenzahlen, in der zweiten die Preise. Und SVERWEIS soll uns die Preise zurückgeben – also den Wert aus Spalte 2.

Das letzte Argument Bereich_Verweis kann WAHR oder FALSCH sein. Es wird hier leer gelassen, das entspricht dem Wert “WAHR”.

Bei WAHR (bzw. ohne dieses Argument) sucht Excel immer den nächst kleineren Wert, der am nächsten am Suchkriterium liegt. Schwimmt jemand 3,5 Stunden (der Wert kommt in der Verweistabelle nicht vor), sucht Excel den nächst kleineren. Es ist notwendig, die Verweistabelle nach der ersten Spalte aufsteigend zu sortieren!

Wenn Excel nur die exakt gleichen Werte suchen soll, müssen Sie das Argument als FALSCH angeben. Dann muss die Verweistabelle auch nicht sortiert sein. Dazu finden Sie ein Beispiel unter Nicht sortierte Tabelle

Quelle: Google.de

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: